[2016 Model] Controller not connecting to the SmartThings network

The Spruce Controller will typically connect to SmartThings in less than 20 seconds. If you are having issues connecting the controller, check the following items.

  1. Both the Controller and the App need to be searching for each other.
    • On the controller, ensure that the Spruce logo is flashing red and blue. If it isn’t, start searching for SmartThings by pressing the Function button (Logo will turn teal color), then Zone 9 (Logo will flash red/blue)
    • In the App, there will be a message that SmartThings is looking, with a circle spinning around.  If this is not happening, navigate to the Marketplace and tap, “+Connect New Device”
  2. It might be a range issue –  Try moving either the hub or Spruce closer until the connection is made.
    • Generally, after the devices have joined, you can move these back to their original locations.  The initial joining is more sensitive to range because the initial wireless power starts lower until it determines that it can run at a higher power.
  3. The Controller may have already connected to SmartThings as a generic or unknown “Thing”.
    • If you back out of the “Connecting” or “Identifying” screen, you might notice a “Not Yet Configured” device at the top of the list in the Marketplace.  Or, in your “Things” list in My Home, you would have simply a generic “Thing” in your list.
    • In this case, you’ll have to remove the Controller from the network (and remove the Thing from the app) first.
  4. Try rebooting the controller
    • Press the Function button, then zone 16. This will ensure that the controller is not joined to anything
    • Unplug the controller, then plug it back in and wait for the controller to finish booting
    • Rejoin as per the normal procedure (in the app, navigate to the Marketplace and tap, “+Connect New Device”; on the controller, press the Function button, then Zone 9)

Was this article helpful?

Related Articles